use strict;
my $str = 'wellsfargo.com
apply.wellsfargo.com
wapppply.wellsfargo.com
test.wellsfargo.com
lending.wf.com
lending-loans.wf.com
yourmortgageapp.wf.com
personal-loan.wf.com
personalloans.wf.com
wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg';
my $regex = qr/^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}