package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com`)
var str = `wellsfargo.com
apply.wellsfargo.com
wapppply.wellsfargo.com
test.wellsfargo.com
lending.wf.com
lending-loans.wf.com
yourmortgageapp.wf.com
personal-loan.wf.com
personalloans.wf.com
wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}