import Foundation
let pattern = #"(?P<main_title>^[A-Za-z]+)\s?\|\s?(?P<show_title>.*[^\s])\s?-\s?(?P<date>[a-zA-Z]+\s\d+)\s?-\s?(?P<show_artist>\w+\s?\W?\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)