const regex = new RegExp('(?P<main_title>^[A-Za-z]+)\\s?\\|\\s?(?P<show_title>.*[^\\s])\\s?-\\s?(?P<date>[a-zA-Z]+\\s\\d+)\\s?-\\s?(?P<show_artist>\\w+\\s?\\W?\\w+)', 'g')
const str = `FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}