use strict;
my $str = 'FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]';
my $regex = qr/(?P<main_title>^[A-Za-z]+)\s?\|\s?(?P<show_title>.*[^\s])\s?-\s?(?P<date>[a-zA-Z]+\s\d+)\s?-\s?(?P<show_artist>\w+\s?\W?\w+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}