// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<main_title>^[A-Za-z]+)\s?\|\s?(?P<show_title>.*[^\s])\s?-\s?(?P<date>[a-zA-Z]+\s\d+)\s?-\s?(?P<show_artist>\w+\s?\W?\w+)").unwrap();
let string = "FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}