import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<main_title>^[A-Za-z]+)\\s?\\|\\s?(?P<show_title>.*[^\\s])\\s?-\\s?(?P<date>[a-zA-Z]+\\s\\d+)\\s?-\\s?(?P<show_artist>\\w+\\s?\\W?\\w+)";
final String string = "FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}