re = /(?P<main_title>^[A-Za-z]+)\s?\|\s?(?P<show_title>.*[^\s])\s?-\s?(?P<date>[a-zA-Z]+\s\d+)\s?-\s?(?P<show_artist>\w+\s?\W?\w+)/
str = 'FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end