import Foundation
let pattern = #"(^\s*)(.+)((?<=\w)\s*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
real
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)