re = /(^\s*)(.+)((?<=\w)\s*$)/m
str = ' Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
real '
subst = '\\U\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result