import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\s*)(.+)((?<=\\w)\\s*$)";
final String string = " Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment\n"
+ " Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment \n"
+ "Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment \n"
+ " Real Economic Impact for Careful àssessment \n"
+ " real ";
final String subst = "\\U\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}