const regex = /(^\s*)(.+)((?<=\w)\s*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\s*)(.+)((?<=\\w)\\s*$)', 'gm')
const str = ` Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
real `;
const subst = `\U\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);