using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s*)(.+)((?<=\w)\s*$)";
string substitution = @"\U\2";
string input = @" Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
real ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}