// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$").unwrap();
let string = "5
50
500
5000
50000
500000
4999999
5000000
6000000
7000000
8000000
8999999
9000000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}