const regex = /([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([5-8]\\d\\d\\d\\d\\d\\d|[8-8]\\d\\d\\d\\d\\d\\d|8999999)$', 'gm')
const str = `5
50
500
5000
50000
500000
4999999
5000000
6000000
7000000
8000000
8999999
9000000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}