using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$";
string input = @"5
50
500
5000
50000
500000
4999999
5000000
6000000
7000000
8000000
8999999
9000000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}