use strict;
my $str = '5
50
500
5000
50000
500000
4999999
5000000
6000000
7000000
8000000
8999999
9000000
';
my $regex = qr/([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}