$re = '/([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$/m';
$str = '5
50
500
5000
50000
500000
4999999
5000000
6000000
7000000
8000000
8999999
9000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);