import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([5-8]\\d\\d\\d\\d\\d\\d|[8-8]\\d\\d\\d\\d\\d\\d|8999999)$";
final String string = "5\n"
+ "50\n"
+ "500\n"
+ "5000\n"
+ "50000\n"
+ "500000\n"
+ "4999999\n"
+ "5000000\n"
+ "6000000\n"
+ "7000000\n"
+ "8000000\n"
+ "8999999\n"
+ "9000000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}