import Foundation
let pattern = #"(([a-z]*\d+[a-z\d\-\\\/]*[\s\,]+)+)(?=([a-z]+[\s\,\b$]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" gg1 4 fgj33, 6778fg, 777ggh5, 567-8/4, ffh g350gh456ghj, fg56gh 455 56gh78 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)