import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-z]*\\d+[a-z\\d\\-\\\\\\/]*[\\s\\,]+)+)(?=([a-z]+[\\s\\,\\b$]))";
final String string = " gg1 4 fgj33, 6778fg, 777ggh5, 567-8/4, ffh g350gh456ghj, fg56gh 455 56gh78 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}