const regex = /(([a-z]*\d+[a-z\d\-\\\/]*[\s\,]+)+)(?=([a-z]+[\s\,\b$]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-z]*\\d+[a-z\\d\\-\\\\\\\/]*[\\s\\,]+)+)(?=([a-z]+[\\s\\,\\b$]))', 'gm')
const str = ` gg1 4 fgj33, 6778fg, 777ggh5, 567-8/4, ffh g350gh456ghj, fg56gh 455 56gh78 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}