#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([a-z]*\d+[a-z\d\-\\\/]*[\s\,]+)+)(?=([a-z]+[\s\,\b$]))"
Local $sString = " gg1 4 fgj33, 6778fg, 777ggh5, 567-8/4, ffh g350gh456ghj, fg56gh 455 56gh78 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")