using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([a-z]*\d+[a-z\d\-\\\/]*[\s\,]+)+)(?=([a-z]+[\s\,\b$]))";
string input = @" gg1 4 fgj33, 6778fg, 777ggh5, 567-8/4, ffh g350gh456ghj, fg56gh 455 56gh78 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}