$re = '/(([a-z]*\d+[a-z\d\-\\\\\/]*[\s\,]+)+)(?=([a-z]+[\s\,\b$]))/m';
$str = ' gg1 4 fgj33, 6778fg, 777ggh5, 567-8/4, ffh g350gh456ghj, fg56gh 455 56gh78 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);