// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:<Th>{(.*)}<\/Th>)").unwrap();
let string = " <Th>{CATEGORY_LABEL.key}</Th>
<Th>{CATEGORY_LABEL.nameKr}</Th>
<Th>{CATEGORY_LABEL.nameEn}</Th>
<Th>{CATEGORY_LABEL.released}</Th>
<Th>{CATEGORY_LABEL.description}</Th>
<Th>{CATEGORY_LABEL.setting}</Th>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}