const regex = /(?:<Th>{(.*)}<\/Th>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<Th>{(.*)}<\\\/Th>)', 'gm')
const str = ` <Th>{CATEGORY_LABEL.key}</Th>
<Th>{CATEGORY_LABEL.nameKr}</Th>
<Th>{CATEGORY_LABEL.nameEn}</Th>
<Th>{CATEGORY_LABEL.released}</Th>
<Th>{CATEGORY_LABEL.description}</Th>
<Th>{CATEGORY_LABEL.setting}</Th>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}