using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<Th>{(.*)}<\/Th>)";
string input = @" <Th>{CATEGORY_LABEL.key}</Th>
<Th>{CATEGORY_LABEL.nameKr}</Th>
<Th>{CATEGORY_LABEL.nameEn}</Th>
<Th>{CATEGORY_LABEL.released}</Th>
<Th>{CATEGORY_LABEL.description}</Th>
<Th>{CATEGORY_LABEL.setting}</Th>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}