// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\((\w+)\/(.*?)\))|([^\( ]+)").unwrap();
let string = "(wav/cc331_a.wav) $vsInpDateTTS (wav/) (wav/b809.wav)
(wav/cc322_b.wav) (num/110)年(num/10)月測試1 (wav/cc322_c.wav)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}