re = /(\((\w+)\/(.*?)\))|([^\( ]+)/m
str = '(wav/cc331_a.wav) $vsInpDateTTS (wav/) (wav/b809.wav)
(wav/cc322_b.wav) (num/110)年(num/10)月測試1 (wav/cc322_c.wav)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end