import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((\\w+)\\/(.*?)\\))|([^\\( ]+)";
final String string = "(wav/cc331_a.wav) $vsInpDateTTS (wav/) (wav/b809.wav)\n"
+ "(wav/cc322_b.wav) (num/110)年(num/10)月測試1 (wav/cc322_c.wav)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}