#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\((\w+)\/(.*?)\))|([^\( ]+)"
Local $sString = "(wav/cc331_a.wav) $vsInpDateTTS (wav/) (wav/b809.wav)" & @CRLF & _
"(wav/cc322_b.wav) (num/110)年(num/10)月測試1 (wav/cc322_c.wav)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")