using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((\w+)\/(.*?)\))|([^\( ]+)";
string input = @"(wav/cc331_a.wav) $vsInpDateTTS (wav/) (wav/b809.wav)
(wav/cc322_b.wav) (num/110)年(num/10)月測試1 (wav/cc322_c.wav)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}