$re = '/(\((\w+)\/(.*?)\))|([^\( ]+)/m';
$str = '(wav/cc331_a.wav) $vsInpDateTTS (wav/) (wav/b809.wav)
(wav/cc322_b.wav) (num/110)年(num/10)月測試1 (wav/cc322_c.wav)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);