import Foundation
let pattern = #"^[\w.:\/%?&=-]+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://demo.test.io/auth/oauth2/realms/root/realms/consumer/authorize?res_type=code&cl_id=demo&scope=openid%20profile&red_uri=https%3A%2F%2Fdemo.test.io%2Fauth%2Fdemo%2Fcb-basic.jsp&state=af0ifjsldkj&ui_locales=de"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}