re = /^[\w.:\/%?&=-]+$/
str = 'https://demo.test.io/auth/oauth2/realms/root/realms/consumer/authorize?res_type=code&cl_id=demo&scope=openid%20profile&red_uri=https%3A%2F%2Fdemo.test.io%2Fauth%2Fdemo%2Fcb-basic.jsp&state=af0ifjsldkj&ui_locales=de'
# Print the match result
str.match(re) do |match|
puts match.to_s
end