package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\w.:\/%?&=-]+$`)
var str = `https://demo.test.io/auth/oauth2/realms/root/realms/consumer/authorize?res_type=code&cl_id=demo&scope=openid%20profile&red_uri=https%3A%2F%2Fdemo.test.io%2Fauth%2Fdemo%2Fcb-basic.jsp&state=af0ifjsldkj&ui_locales=de`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}