const regex = /^[\w.:\/%?&=-]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w.:\\\/%?&=-]+$', '')
const str = `https://demo.test.io/auth/oauth2/realms/root/realms/consumer/authorize?res_type=code&cl_id=demo&scope=openid%20profile&red_uri=https%3A%2F%2Fdemo.test.io%2Fauth%2Fdemo%2Fcb-basic.jsp&state=af0ifjsldkj&ui_locales=de`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}