#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\w.:\/%?&=-]+$"
Local $sString = "https://demo.test.io/auth/oauth2/realms/root/realms/consumer/authorize?res_type=code&cl_id=demo&scope=openid%20profile&red_uri=https%3A%2F%2Fdemo.test.io%2Fauth%2Fdemo%2Fcb-basic.jsp&state=af0ifjsldkj&ui_locales=de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")