import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w.:\\/%?&=-]+$";
final String string = "https://demo.test.io/auth/oauth2/realms/root/realms/consumer/authorize?res_type=code&cl_id=demo&scope=openid%20profile&red_uri=https%3A%2F%2Fdemo.test.io%2Fauth%2Fdemo%2Fcb-basic.jsp&state=af0ifjsldkj&ui_locales=de";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}