// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((?:"pin"\s*:\s*"|"secretCode"\s*:\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\/pin>|<\/secretCode>))"#).unwrap();
let string = "{
\"pin\":\"0000\",
\"secretCode\":\"0000\"
}
<xml>
<pin>0000</pin>
<secretCode>0000</secretCode>
</xml>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}