package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:"pin"\s*:\s*"|"secretCode"\s*:\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\/pin>|<\/secretCode>))`)
var str = `{
"pin":"0000",
"secretCode":"0000"
}
<xml>
<pin>0000</pin>
<secretCode>0000</secretCode>
</xml>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}