const regex = /((?:"pin"\s*:\s*"|"secretCode"\s*:\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\/pin>|<\/secretCode>))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:"pin"\\s*:\\s*"|"secretCode"\\s*:\\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\\\/pin>|<\\\/secretCode>))', 'gm')
const str = `{
"pin":"0000",
"secretCode":"0000"
}
<xml>
<pin>0000</pin>
<secretCode>0000</secretCode>
</xml>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}