re = /((?:"pin"\s*:\s*"|"secretCode"\s*:\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\/pin>|<\/secretCode>))/m
str = '{
"pin":"0000",
"secretCode":"0000"
}
<xml>
<pin>0000</pin>
<secretCode>0000</secretCode>
</xml>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end