using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:""pin""\s*:\s*""|""secretCode""\s*:\s*""|<pin>|<secretCode>))[0-9]{4}(?:(""|<\/pin>|<\/secretCode>))";
string input = @"{
""pin"":""0000"",
""secretCode"":""0000""
}
<xml>
<pin>0000</pin>
<secretCode>0000</secretCode>
</xml>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}