import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\"pin\"\\s*:\\s*\"|\"secretCode\"\\s*:\\s*\"|<pin>|<secretCode>))[0-9]{4}(?:(\"|<\\/pin>|<\\/secretCode>))";
final String string = "{\n"
+ "\"pin\":\"0000\",\n"
+ "\"secretCode\":\"0000\"\n"
+ "}\n"
+ "<xml>\n"
+ "<pin>0000</pin>\n"
+ "<secretCode>0000</secretCode>\n"
+ "</xml>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}