import Foundation
let pattern = #"([tk]) . b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
? ' a l t . b aU
m u . z ' i: k . b r a n . C @
r ' Y k . b @ . ts y: . k l I C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 . p"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)