use strict;
my $str = '? \' a l t . b aU
m u . z \' i: k . b r a n . C @
r \' Y k . b @ . ts y: . k l I C';
my $regex = qr/([tk]) . b/mp;
my $subst = '\\1 . p';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";