re = /([tk]) . b/m
str = '? \' a l t . b aU
m u . z \' i: k . b r a n . C @
r \' Y k . b @ . ts y: . k l I C'
subst = '\\1 . p'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result