import Foundation
let pattern = #"^\[(?<group>.*)(?<!:children)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[man-aged-sql:children]
ManagedMSSQLDBMS2016DBAMode
ManagedMSSQLServer2016
ManagedMSSQLServer2017
[all_managed:children]
server01
server02
[notmanaged]
server04
server05
[ManagedMSSQLServer2016]
Server4
Server5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)